Possible solution to PPP issue!!

Gamer's Internet Tunnel, formerly Gamer's IPX Tunnel

Possible solution to PPP issue!!

Postby Monkey Giblets » Thu Jun 24, 2004 6:30 pm

Ok just as a pretext my issue was that i wanted to join some LAN joint operations servers but my pc connects to the internet via an ADSL card that uses PPPOA. GIT manipulates ethernet frames which caused a problem as i dont have an ethernet home network or etherent card.

I dont know whether this solution has been posted before nor whether it will work for all games but here goes.

What you want to do is install a loopback device which will act as a virtual ethernet card if you will, in windows xp you can do this by running the add new hardware configuration, going to advanced and selecting the microsoft loopback device driver (may not be available in previous windows OS's).

Once installed you will want to give this driver a private IP address (e.g. 192.168.1.1) subnet mask and default gateway. Make the default gateway your external IP address as assigned by your ISP.

Then go into the GIT advanced configuration and select alter source IP (bottom right corner) make the From Hostname (internal): the IP address of your loopback device and the To Hostname (external): the IP address assigned to you by your ISP.

That should have the effect of creating an ethernet LAN game frame on the loopback device, the packet(s) Source address being manipulated and being sent out your PPP device.

The above is a bit sketchy and ill try to put together some how-to screenies if people want them. Sorry if this solution has been discused before but i couldnt find any post.
Monkey Giblets
 
Posts: 2
Joined: Thu Jun 24, 2004 6:17 pm

Postby Ark » Thu Jun 24, 2004 7:00 pm

Thats a very good idea actually, I can confirm that Windows 2000 has a MS Loopback adapter available to install as well. This would work for dialup modem users who don't have an ethernet card installed as well.
Ark
Site Admin
 
Posts: 2108
Joined: Sat Sep 13, 2003 4:21 pm

Postby Monkey Giblets » Fri Jun 25, 2004 4:59 am

I have a set of screen shots of how to set it up in Windows XP but no where to host them???
Monkey Giblets
 
Posts: 2
Joined: Thu Jun 24, 2004 6:17 pm

Postby Ark » Fri Jun 25, 2004 11:53 am

zip them all up and if its under 5 megs or so, you can email them to me.
Ark
Site Admin
 
Posts: 2108
Joined: Sat Sep 13, 2003 4:21 pm

Postby bgr » Sun Aug 15, 2004 3:35 pm

and where are the screenshots ?

i would like to see them just to be sure i've done everything right.

REMINDER: Please post your questions, thoughts, or requests here. We will answer your post within 12 hours - much quicker than email.
bgr
 
Posts: 1
Joined: Sun Aug 15, 2004 3:27 pm

Postby Ark » Mon Aug 16, 2004 11:09 pm

I havn't seen any email with screenshots yet. Also the 12 hour thing applies to programs we can officially support. GIT is not one of those unfortunately.
Ark
Site Admin
 
Posts: 2108
Joined: Sat Sep 13, 2003 4:21 pm

Postby CalliduS » Tue Sep 21, 2004 6:56 pm

CalliduS
 
Posts: 34
Joined: Sat Sep 18, 2004 3:33 am
Location: UK

Postby mrgcypher » Wed Apr 13, 2005 5:13 am

please see
http://winpcap.polito.it/misc/faq.htm#Q-13
WInpcap doesn't support loopback.....
mrgcypher
 
Posts: 2
Joined: Tue Apr 12, 2005 6:54 am


Return to GIT

Who is online

Users browsing this forum: No registered users and 0 guests

cron