Photoshop PSD file not recognized

Make sure to search and see if your bug has already been posted

Photoshop PSD file not recognized

Postby LeightonO » Sat Feb 28, 2009 2:30 pm

Occasionally when I try to open a (Photoshop) PSD file I get an error: Failed to load picture: Reason: File is not a valid PSD file.

Clearly these are PSD files.

Program works fine when opening JPEG, TIF images and some PSD files.

Size (file) does not seem to matter. (Sorry, no pun intended)

Any reason for this failure to open?
LeightonO
 
Posts: 2
Joined: Sat Feb 28, 2009 2:20 pm
Location: Phoenix Arizona

Postby Ark » Sat Feb 28, 2009 3:29 pm

PSD files can contain all kinds of information that most programs don't care about, and Adobe can change the format with newer versions however they want. It is simply not a standard file format for pictures and not something that can be guaranteed to always be loadable. Morpheus does it's best to read images from PSD files, but PNG or JPG will always be the best bets for compatibility.
Ark
Site Admin
 
Posts: 2108
Joined: Sat Sep 13, 2003 4:21 pm

Postby LeightonO » Sun Mar 01, 2009 10:26 am

I understand, Thanks. Love the program btw
LeightonO
 
Posts: 2
Joined: Sat Feb 28, 2009 2:20 pm
Location: Phoenix Arizona

Trouble with loading files

Postby Scarabus » Sun Jun 14, 2009 2:58 pm

Mac, latest software, lots of memory.

Heretofore I've had no problems as all. Today when I ran the program, I was a told a new version was available. I downloaded and installed it. Afterward PSD was dissed (same file that was accepted Friday). I saved it in other formats (TIFF, PNG, JPG, etc.). The other formats loaded, but colors were bizarre.

I trashed the new version and reinstalled the earlier one. Same result. With Macs, a good plan is to delete preferences and try again. I'll do the usual stuff, but in meantime wanted to make sure the answer wasn't already available.

Thanks.
Scarabus
 
Posts: 2
Joined: Sun Jun 14, 2009 2:46 pm

Update on Mac files

Postby Scarabus » Tue Jun 16, 2009 3:22 pm

I did everything I could think of, to no avail: PSD wasn't recognized and other formats came up with weird colors.

However, when I skipped past the first part of the wizard, everything worked.
Scarabus
 
Posts: 2
Joined: Sun Jun 14, 2009 2:46 pm


Return to Bug Reports

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron