Page 1 of 1

"Unable to open the packet device" in Vista

PostPosted: Thu Oct 12, 2006 7:10 pm
by Sephiroth
I get this error:
when running GIT after installation, without any configuration. I asked someone else who is using GIT on XP and they said they have never seen it before, and I got someone else on Vista to try using GIT and they get the same error.

Any ideas?

PostPosted: Thu Oct 12, 2006 7:35 pm
by Ark
WinPCap may not support Vista, or the version included with GIT may be too old. You could always try a newer version of WinPCap from their website.

PostPosted: Thu Oct 12, 2006 7:51 pm
by Sephiroth
Excellent, thanks. I got the Winpcap v4 beta 2. Thanks for the help :)

unable to open packet device in VISTA

PostPosted: Thu Mar 08, 2007 4:38 pm
by Genool
Has anyone found a cure for this problem? I am trying to hook up with another computer at home, but GIT cannot find any devices. My device window is empty.

Any suggestions would be great!!..

GIT with vista

PostPosted: Thu May 17, 2007 9:02 pm
by technomancer
Get winPCap 4 from their site and run GIT as the administrator and you should get some devices.

PostPosted: Fri May 18, 2007 9:11 pm
by ack
Coolness! That seems to have fixed it!


by the way

PostPosted: Fri May 18, 2007 10:43 pm
by technomancer
it doesnt work if you set it to run on start up but i think it doesnt need to b run as the admin after the first time

it always needs admin privalegdes

PostPosted: Fri May 18, 2007 10:46 pm
by technomancer
you have to always run it as the admin.

PostPosted: Sat May 19, 2007 2:01 pm
by ack
Dang, well I can run GIT now, but it won't connect up to another computer. Same settings as was on XP.

I'll run some more tests, but if anyone has got it to work, please say how.

what is your ip address

PostPosted: Sun May 20, 2007 12:32 am
by technomancer
can you give me your external ip adress so that we can test if two computers using GIT on vista can connect together? :D :idea:

PostPosted: Mon May 21, 2007 10:54 am
by ack
Well, I got it to work with my two PCs at home. Alright!

Technomancer, hey no point in trying with me because my external IP changes more often than a baby and diapers (I'm on DSL). ;)

Oh, one thing I noticed (not specifically with Vista). GIT needs to run as high priority to work right. Running with normal priority, GIT tends to get CPU starved by whatever game is running.

PostPosted: Sat May 26, 2007 1:54 pm
by ack
Dang! Well, something's different with Winpcap 4.0. I can establish a connection, get 3 lines in status, but can't ping or see a friend's computer.

Could be something to do with Vista too, but I'm not sure. :?

winpcap 4.0

PostPosted: Sat May 26, 2007 11:00 pm
by technomancer
i have no previous experience with GIT or winpcap but if you are not both using the same version of winpcap then it will probably fail its connection. I say this with no experience so if this is not true dont criticise me. it is just that windows, computers and programs that run on computers running windows are incredibly picky about these things. Therefore is would probably help to make sure that the two installations are as similar as possible.!!!!!!!

PostPosted: Sun May 27, 2007 7:17 pm
by ack
Yeah I thought that might be the case, so Winpcap 4.0 was used on both sides.

It's either a Vista issue or Winpcap, but no time to isolate it further for now. :?

PostPosted: Sun May 27, 2007 7:31 pm
by Ark
The version of winpcap does not need to be the same on each side, it has nothing to do with how GIT itself communicates to the other GIT running on the opposite network.