Major problems with M1TP2

Gamer's Internet Tunnel, formerly Gamer's IPX Tunnel

Major problems with M1TP2

Postby PhakeDC » Wed May 24, 2006 8:20 am

I'm trying to play a LAN game of M1 Tank Platoon 2 over my LAN, but everytime I try to host a game over TCP/IP I receive the ancient modem dialog from Win9X,


and I can't seem to get around it. Fired up google and ended up with the following out-of-date tip from Microprose

We're using TCP/IP for our LAN network protocol, and it doesn't seem to work.
TCP/IP and Dial up For TCP/IP connections, ensure the Dial-UP networking is set to ""Don't Prompt"" to use ""Dial-Up Networking."" This is set in the Dial-Up Networking program located in your Start Menu/Programs/Accessories/Dial-UP Networking icon. In addition, make sure that Dial-Up Networking is loaded before starting any multiplayer M1 Tank Platoon II game. DirectPlay required for multiplayer The first thing is to put the newest version of DirectPlay on your system.The install of M1 looks like it does this, but in fact the DirectPlay files are not on the CD. You can get it as part of DirectX 5.2 or higher, form Microsoft at the link below. Also if you got to your Start button and choose ""Run"" and type in SYSEDIT You can look at your WIN.INI file. If you do not see the following two lines you should add them in at the end: [LibsysNetwork] regulartcpipenabled=true Click on the link(s) below to obtain the appropriate update file: Download DirectX from the Microsoft site

Well I did the win.ini thing but it didn't help. I don't think there's a way to prevent the dialog from popping up!!! So short of messing with virtualisation, is there a way to access legacy Dialup networking options in Windows XP or 2003? Oh and Virtual Modem Pro sucks.. their documentation is virtually nonexistent as well. And this coming from an ex-technical writer :-S

I have tried GIT but to no avail. I run a server (Win2003 R2)-client (WinXP SP2) LAN, and installed IPX on both machines, and configured generic IPX settings in GIT. When I host a game I get the following dialog, I choose COM1 yet the other party doesn't see the server. Any clues? Thanks for all your help.


Oh and DirectPlay applet doesnt work.. I tested it and client PC can't join the IPX session hosted on the server (or vice versa)
Posts: 1
Joined: Wed May 24, 2006 8:00 am

Return to GIT

Who is online

Users browsing this forum: No registered users and 2 guests