Can ping with TCP but ping rises, cannot ping with UDP :'(

Gamer's Internet Tunnel, formerly Gamer's IPX Tunnel

Can ping with TCP but ping rises, cannot ping with UDP :'(

Postby wizwiz » Mon Sep 12, 2005 8:02 am

Hello everybody,
I found GIT a few time ago, seems really nice :D !

I spend several hours trying to set GIT. I managed to connect using TCP. Ping is about 50ms, which is enough for me, but randomly few times later ping is getting very high (3500-5000 ms).

I tried to use UDP faster connection but i don't manage to ping anything :'(.

Here is my network and my settings :

--our network--

Site 1 :
Router1 RP614v2: (forward port 213, no udp or tcp choice)
PC1: /

Site 2:
Router2 RP614v3: (forward port 213, no udp or tcp choice)

--ours GIT Settings--

PC1 & PC2 advanced settings (for TCP and UDP)
I don't think we have to change anything for TCP or UDP.

-configs for TCP-


With those settings we managed to ping each other but few minute after being connect, ping rises crazy. If we disable/enable git fast then ping get back to 50ms.

We tried UDP with those settings :
but we don't managed to get ping response :'(

Does anyone see what we're doing wrong ?
I think TCP connection would be enough without that weird ping drop (we tried several time to run pingx1000 without doing anything in the meantime but we still got the problem).

Maybe getting UDP working would allow us to avoid this ping drop problem.

Thank you for your help :roll:
Posts: 3
Joined: Mon Sep 12, 2005 6:35 am

Postby wizwiz » Mon Sep 12, 2005 12:01 pm

I tried again UDP-fastest.

With netpeeker (a firewall which can sniff and do a lot of things) on my friend's computer i saw that, when GIT was on UDP transfer mode, no packets were send.

On my computer, netpeeker shows that GIT is sending data by UDP even if no client is listening (which is logical). But on my friend's one, there's no any byte send by GIT :'(

Does someone as any idea ? Why GIT won't send anything from his computer ?

- I tried different port (with admin rights) 213, 215, 6000...
- Netpeeker shows UDP traffic for other software on his computer.
- Other softwares using UDP work like a charm

i don't have a clue ;;

I tried another time today, incoming.log isn't empty on the two PC. So I was wrong, some UDP packet are sent.
My pings still fail in "UDP faster" :'(
I made a VPN to try to play at warcraft III without battlenet but it seems the aren't working either.
PLEeeeeeeeeease help me ^^;;
Posts: 3
Joined: Mon Sep 12, 2005 6:35 am

Postby karma » Tue Sep 20, 2005 2:44 pm

hello wizwiz

i have some things for you

I will describe Your Scenario:
You are both using routers,
You are both using a LAN that, together, does not have IP address conflicts.
That is the normal scenario for GIT.

You only need 'alter source IP' when you are playing a tcp/udp game, in a game lobby, where direct IP connection is possible, example WC3 and EE2. I a lobby, you can see the game list because the game host GIT is sending a periodic broadcast. The game client can see the game list. 'Alter source IP' is useful when you want to cause clients to connect to the game host on the host's Internet IP, not the host's GIT LAN IP, because why do you want to have your GIT work harder, when the game can connect normally over the internet, without GIT? GIT is only forwarding broadcasts (game lobby) to everyone. This does require the host to have the proper tcp/udp port forwarded in their router. This also only works for tcp/udp games. I hope that helps you understand.

Ok. On to bigger & better things.

in the GIT Advanced config, place a checkmark for "don't send routable."

in the GIT config, use UDP method. Make the tcp/udp ports empty.
Armed with your compatible LAN, UDP method, and no GIT tcp/udp ports, you should now test your connection.

Ping your friend's 192.168 address.

If you want to go deeper, use GIT logging and compare GIT incoming log and forwarded log between yourselves. Make sure the timestamps co-relate. Look for ICMP, ARP request, ARP reply, and UDP packets 'from' and 'to' your 192.168 addresses.

This should work marvelously. Then, when you see that your pings are clear, open git config and forward only the necessary tcp/udp port(s). Don't blanket-forward the whole list! that can cause unnecessary lagging. Refer to's list of common ports or use google to find the port you need to forward, which will usually be the UDP port(s) if your results are a list of ports.

Let me know, contact me on IM if you like, if you want help.

Posts: 69
Joined: Mon Mar 14, 2005 7:42 am
Location: yokosuka japan

Postby wizwiz » Thu Sep 22, 2005 12:07 pm

Thank you for your help, we tried your settings (we might tried every settings :) ) but i don't managed to ping his computer in UDP transfer mode (but ping in TCP conect/listen mode is working).

We installed windows XP SP1 pro instead of SP2 pro because he just bought a new PC. It still doesn't work ;;

I heard that Netgear's RP614v2-3 firmware was buggy, maybe it has something to do with that.

Thank you very much for your help ^^
Posts: 3
Joined: Mon Sep 12, 2005 6:35 am

Return to GIT

Who is online

Users browsing this forum: No registered users and 2 guests