Anyone use this with Act of War: Direct Action ?

Gamer's Internet Tunnel, formerly Gamer's IPX Tunnel

Anyone use this with Act of War: Direct Action ?

Postby f2a » Fri Mar 18, 2005 8:46 pm

I was wondering if anyone has succeeded in using GIT to play Act of war: direct action.
Posts: 1
Joined: Fri Mar 18, 2005 8:43 pm

Postby Stone1269 » Sun Mar 20, 2005 10:50 am

Yes...a friend and I tried this game yesterday with GIT and it worked perfectly.
Posts: 1
Joined: Sun Mar 20, 2005 10:48 am

Postby jahamala » Sun Mar 20, 2005 12:43 pm

Any particularly funky settings you used? It's my frist try with this program, but I couldnt get it to work. Just my friend and I tried it with me on TCP listen connection and him connected to me. The only port forwarded was 12222. It seemed like we were connected, but nothing showed up in the game.
Posts: 4
Joined: Sun Mar 20, 2005 12:40 pm

Postby jahamala » Sun Mar 20, 2005 9:42 pm

I've got it working, but only if I forward "All the rest" ports 217-65535. I cant seem to narrow it down any. The logs of incoming ports jump all over the place. The lag is only marginal, around 150-200ms. It's not noticable in an RTS really anyway so I'll probably stick with this unless someone knows better how to filter out what ports are needed. 12222 seems to be the most popular. It was there about a zillion times. But then there's probably 100 or so more ports scattered throughout the log. I don't know what they're coming from or how to weed them out better. If someone figures out the exact port range, let me know.

Sun Mar 20 22:32:05 2005] *ip removed*: hw:00:e0:18:d8:5a:08 EthernetII IPv4 UDP to: from: 'ok'

EDIT - Also, it's working on UDP just fine, no need for TCP. Just have to have "Forward ARP" checked. I know it creates more lag, but I couldnt get it to work without it.
Posts: 4
Joined: Sun Mar 20, 2005 12:40 pm

Postby sebiel » Sat Mar 26, 2005 12:12 pm

Can you write in detail how you did this? My friend and I can't get it working at all.

We're forwarding the 213 port we're using on GIT through the router-- how exactly do we set up our connections though? Both of us UDP or TCP or what? Does one of us have to be a listen server? We're really lost...
Posts: 1
Joined: Sat Mar 26, 2005 12:10 pm

Postby jahamala » Sat Mar 26, 2005 9:16 pm

If it's just you and one other person, you can both connect to each other with UDP Fastest on port 213.

I don't know how your network is set up, but I'll tell you how my friend and I who are both NAT'ed got it to work with 0.99b4.

First, you put in his ip and port 213, select UDP Fastest and Add it. Then at the bottom right you add 217-65535: All the Rest (this can be narrowed down to help with lag, but haven't had luck with finding a smaller range). Nothing needs to be added at top right. Then, your friend does the same thing, except he uses your IP of course.

Under advanced config, only check these options:
Ethernet II
Forward ARP
Zlib Compression
ICMP (probably not needed)
Also Match Source Port
Don't Send Routable.

The most important and hardest part for people to understand is that you can't have any conflicting IP addresses between you and your friend, and you have to be on the same subnet. Therefore, your routers can't both be set to Yours has to be and his .2 or something different. Make sure none of the PC's on each of the networks have conflicting IP's either. I have mine set to and my router set to My friend has his set to with his router set to, both of us on subnet

With all these settings, we have lag of about 140ms or so. Not bad for an RTS. It could be bettered with less ports forwarded, or maybe trying different options in Advanced. I'm betting TCP and ICMP probably don't need forwarding. Anyway, good luck, and if anyone can help me narrow down the ports for this game, please post. We've seen everything from 3400-5000 and 12222 , but setting that range doesn't work. The host usually has a port close to 5000, while the client usually has two ports close to 3400. There must be a port up in the 5 digit range because the Common Ports option doesn't work.
Posts: 4
Joined: Sun Mar 20, 2005 12:40 pm

Postby karma » Sun Apr 03, 2005 5:40 am

the best way to check ports used by a program is to run the program in its various network modes (lobby, chat room, game start, game in progress, etc)

for each mode, use task manager (ctrl+alt+del) and go to the processes tab. go to view menu, pick select columns, put a check in the PID box. press ok.

then from winxp console (start/run, type cmd, press enter) type Netstat -a -o and press enter.

that will list off all network processes. match the PID number listed with your game's process (from task manager) and you will see the ports used (left column are your computer's ports, middle column is remote host port if connection is other than listening state)

in Git, forward the tcp/udp port that your game process is listening on.

That's the best way i can think of to phish out the ports a process uses.
Posts: 69
Joined: Mon Mar 14, 2005 7:42 am
Location: yokosuka japan

Postby Ark » Sun Apr 03, 2005 11:02 am

Netstat does not always show ports that may be used later on, or are not bound as listening ports, which case be the case for UDP a lot.
The best way is really to just look at the logs. All traffic will either show up in unforwarded.log or forwarded.log depending on your options, so if you see something in unforwarded.log that you need forwarded, just add the right options in, and it will be forwarded.
Site Admin
Posts: 2108
Joined: Sat Sep 13, 2003 4:21 pm

Postby jahamala » Mon Apr 04, 2005 4:08 pm

The problem with the game is that it's a random port within a certain range every time. For the host, the port is always close to but not higher than 5000. For the clients there's usually 2 ports close to but not below 3400. Then there's always a few random ports way up in the 60k range being used. So far the best we can narrow it down is 3400-5000, 12222, and 60k-65535. It only uses UDP though, so lag isn't bad since almost no common programs besides games use UDP and most of those ports aren't used anyway.
Posts: 4
Joined: Sun Mar 20, 2005 12:40 pm

Postby bubbasmith » Thu Feb 02, 2006 7:37 pm

Weird, can't get this to work. Setup is as follows:

My PC:
My Router:

Friend's PC:
Friend's Router:

Both PCs in DMZ

Using GIT v0.99b4

Under configuration, have each others' external IP, port 213, UDP, forwarding 1-212, 241-65535

Under Advanced, have Ethernet II, Forward ARP, ZLib Compression, TCP, UDP, ICMP, Also Match Source Port, Don't Send Routable checked

In the connection status for GIT, both of us see each other as UP, seems to work fine, except Act of War doesn't work at all - can't see the created game at all.

What gives?
Posts: 1
Joined: Thu Feb 02, 2006 7:28 pm

Return to GIT

Who is online

Users browsing this forum: No registered users and 1 guest