need help with a Lan game over the Internet

Gamer's Internet Tunnel, formerly Gamer's IPX Tunnel

need help with a Lan game over the Internet

Postby Loopin3r » Fri Nov 12, 2004 2:12 pm

trying to play Need for speed underground 2 over the internet and cant figure out what to do, can someone point me in the right direction?
Loopin3r
 
Posts: 2
Joined: Fri Nov 12, 2004 2:09 pm

Postby Shrek » Fri Nov 12, 2004 6:55 pm

It works for me:

IP x.x.x.x
port 213
TCP Connect

and forwarded for udp/tcp ports (client and server):
1-212 All below GIT
217-65535 All

the ports needed for NFSU2, so maybe i did a overkill with forwarding
TCP ports: 80, 13505, 20920-20929, 20970-20979
UDP port addresses: 3658, 3659

Image
Shrek
 
Posts: 1
Joined: Fri Nov 12, 2004 6:51 pm

Postby Tomahawk » Sat Nov 13, 2004 11:21 am

He Shrek,
we try it too, but it doesn't work.

We take your config 1:1, but no Lan-Server is shown in NFSU2.

Question: Why you have 2 connections added in Client?

How you are connected to the Internet? Ist there a trick with several IPs assigned to a computer? 1 for local-lan, 1 for internet ect.

Lets go in more Detail.

Tanx.
Tomahawk
 
Posts: 3
Joined: Sat Nov 13, 2004 11:17 am

Postby Mistikal » Sat Nov 13, 2004 12:05 pm

Yea were having the same prob, me and my m8 are conected via GIT (or so it seems) but we cannot see any lan games.

What is the exact port for NFSU2?
Also we are very new to GIT so a step by step guide would be appreciated, we followed the other one to get connected.

And shrek, this bit:

the ports needed for NFSU2, so maybe i did a overkill with forwarding
TCP ports: 80, 13505, 20920-20929, 20970-20979
UDP port addresses: 3658, 3659

Where did you enter this? in the Forward which TCP/UDP ports bit?
Mistikal
 
Posts: 5
Joined: Sat Nov 13, 2004 11:59 am

Postby Tomahawk » Sat Nov 13, 2004 2:46 pm

It's not hard. We tune GIT like said a few threads before.

Now we can see the open game, but when you try to enter this game, it runs endless. (connecting to lobby)

Not sure, this is a NFSU2 Problem or our config is *censored*.

Just want to see someone, who get it running. Good luck. We wait for it.
Tomahawk
 
Posts: 3
Joined: Sat Nov 13, 2004 11:17 am

Postby Loopin3r » Mon Nov 15, 2004 12:49 pm

Anyone figure it out yet?
Loopin3r
 
Posts: 2
Joined: Fri Nov 12, 2004 2:09 pm

Postby taz_eat » Mon Nov 15, 2004 6:01 pm

well i know nfsu2 uses udp port 9999 to find other comps on lan.. that should definately be forwarded.

edit:
well forwarding everything except 213

i get same thing
"Now we can see the open game, but when you try to enter this game, it runs endless. (connecting to lobby)"

well it isnt endless as it does end with error.
taz_eat
 
Posts: 15
Joined: Thu Oct 07, 2004 11:46 pm

Postby distance » Thu Nov 18, 2004 3:40 pm

It works ! :D
NFSU2 LAN over GIT

---
Using method: UDP - Fastest
---
Forward which TCP/UDP ports:
80
9999
---
distance
Troll
 
Posts: 13
Joined: Thu Nov 18, 2004 3:34 pm

Postby komat » Mon Nov 22, 2004 7:13 pm

can someone post pics of configs or liste configs on client and server


i want to connect two pcs but both pcs are connected by winxp ics


what do i need to do
komat
 
Posts: 5
Joined: Mon Nov 22, 2004 7:07 pm

Postby Lobinio » Wed Nov 24, 2004 5:37 am

The only messages which need forwarding with GIT are the broadcast messages on UDP port 9999.

If you are NAT/FWed then you need of course to forward/allow in your router/fw UPD port 3658 where the actual game traffic is sent through. Also the port for GIT ;)

When you are connected via ICS make sure you have GIT listen on the NIC on your LAN side (can be set in advanced config).

happy racing :)
Lobi
Lobinio
 
Posts: 1
Joined: Wed Nov 24, 2004 5:25 am

Postby komat » Thu Nov 25, 2004 1:16 am

so do you run the client on the pc with the internet or the pc with the game?


this is too confusing

can someone tell me what i need to do

lets this pc ip is 10.0.0.1

the other ip is 11.0.0.1

what do i need to do to get it working
komat
 
Posts: 5
Joined: Mon Nov 22, 2004 7:07 pm

Postby huwkka » Thu Nov 25, 2004 2:33 am

first of all put the one pc's ip to 10.0.0.1 and other one's to 10.0.0.21 and the subnet mask to 255.0.0.0

Other than that i cannot help you with.
huwkka
 
Posts: 12
Joined: Tue Nov 23, 2004 3:48 pm

Postby komat » Thu Nov 25, 2004 12:28 pm

that doesnt help at all...
doesnt tell much
komat
 
Posts: 5
Joined: Mon Nov 22, 2004 7:07 pm

Postby Ark » Thu Nov 25, 2004 3:34 pm

I think he makes a valid point: put the two computers in the same subnet with the same subnet mask as if they were on the same network.
Ark
Site Admin
 
Posts: 2108
Joined: Sat Sep 13, 2003 4:21 pm

Postby komat » Thu Nov 25, 2004 8:50 pm

i used winxp vpn so mcuh esier then this
komat
 
Posts: 5
Joined: Mon Nov 22, 2004 7:07 pm

Next

Return to GIT

Who is online

Users browsing this forum: No registered users and 7 guests

cron