Connected But Cannot Ping

Gamer's Internet Tunnel, formerly Gamer's IPX Tunnel

Connected But Cannot Ping

Postby Muppet » Fri Dec 05, 2008 3:34 pm

We are trying to connect two machines across the internet, we can see in connection status that we are connected and are forwarding packets but still can't ping.

We are both using Vista 64-bit and have enabled incoming and outgoing rules for ICMP

We have NATd port 213 on our routers

We have allowed UDP and TCP port 213 in firewalls

In configuration:
We have added the opposite machines IP using 213 for UDP Fastest, TCP connect, TCP listen

We have forwarded; All below Git Range, Common Ports, All the rest

In Advanced Configuration:
We have ticked; Ethernet II, Forward ARP, TCP, UDP, ICMP, Also Match Source Port - We have also tried using Alter Source IP for NAT

We have checked the the incoming.log and forwarded.log and it shows the pings as ok but the command prompt shows them as either request timed out or as destination host unreachable

We have tried a couple of different games and they don't connect.

Any ideas??? Thanks.
Posts: 1
Joined: Fri Dec 05, 2008 3:14 pm

Postby karma » Mon Dec 29, 2008 12:38 am

any luck yet?
i don't have experience with vista of any flavor but i do with xppsp2

so how is each of your LANs set up?
are you on a compatible subnet?
do you have a packet sniffer to trace with? i use networkspy, it shows both the git traffic (port 213 <--> port 213) and the tunneled traffic as git untunnels it. I have used the presence or lack of 213--213 traffic to troubleshoot connections. if you find that you are not having a connection to begin with, try tcp connect method, one person tcp listen and the other tcp connect.

As far as LAN setup, for example. if your router's LAN IP is then your friend's router cannot be the same can be something similar like Also, your computers/printers must have separate addresses, so there is no conflict between your machines and all machines on the other LAN. you see, the 192.168.1 part of the local IP addresses must match for you and your friend's LAN, while you are on subnet mask.

once your addressing schemes are good to go, then tickoff as you mentioned in the advanced config, with the exception of "alter source ip." you do not need to use that for your situation.

Using GIT config, forward only the ports that you need...mass-forwarding all ports will bogg down your link. research and find the ports you need. better yet, establish a connection first (good pings) and then decide what ports to add to the config for forwarding.

to test with, i am not 100% sure if vista64 is happy letting pings fly... good luck.
Posts: 69
Joined: Mon Mar 14, 2005 7:42 am
Location: yokosuka japan

Return to GIT

Who is online

Users browsing this forum: No registered users and 4 guests